<!DOCTYPE html>
<html lang="en" class="no-js">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">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</script>
<meta property="og:title" content="Rock Hall and Jonathan Demme Bring the &#039;Power of Rock&#039; to Cleveland in a New Experience" />
<link href="http://mediad.publicbroadcasting.net/p/wksu/files/201706/hughes.jpg" rel="image_src" />
<meta name="datePublished" content="2017-06-30" />
<meta property="og:type" content="article" />
<meta name="description" content="The Rock and Roll Hall of Fame unveils its $9 million &quot;Power of Rock&quot; theater Saturday, which features a seat-rumbling film of inductees by director" />
<meta property="og:url" content="http://wksu.org/post/rock-hall-and-jonathan-demme-bring-power-rock-cleveland-new-experience" />
<meta content="Rock Hall and Jonathan Demme Bring the &amp;#039;Power of Rock&amp;#039; to Cleveland in a New Experience" about="/post/rock-hall-and-jonathan-demme-bring-power-rock-cleveland-new-experience" property="dc:title" />
<link rel="shortcut icon" href="http://mediad.publicbroadcasting.net/p/wksu/files/201602/favicon.ico" type="image/vnd.microsoft.icon" />
<meta property="twitter:card" content="summary" />
<meta property="og:image" content="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201706/hughes.jpg" />
<meta property="og:description" content="The Rock and Roll Hall of Fame unveils its $9 million &quot;Power of Rock&quot; theater Saturday, which features a seat-rumbling film of inductees by director" />
<meta name="story_id" content="534971485" />
<meta name="wordCount" content="366" />
<link rel="shortlink" href="/node/26191" />
<link rel="canonical" href="/post/rock-hall-and-jonathan-demme-bring-power-rock-cleveland-new-experience" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime();</script>
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="has_audio" content="1" />
<meta name="programs" content="none" />
<meta name="org_id" content="0" />
<meta name="author" content="Kabir Bhatia" />
<meta name="nid" content="26191" />
<meta name="category" content="Arts &amp; Culture" />
<meta name="keywords" content="Rock and Roll Hall of Fame, Glenn Hughes, Deep Purple, Greg Harris, Chris Connor, Prince" />
    <title>Rock Hall and Jonathan Demme Bring the &#039;Power of Rock&#039; to Cleveland in a New Experience | WKSU</title>
    <link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_zXr1pRkjUmFHX10b6Pv5_DqzyewvdLNQ8QgccGQIRQQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_ZFlaYqkiQzTmlBPX4mQeT33IFQX3nR-zpGlyqFhtTNM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_XHTm2cMU6sD6pzlNwtS19lgDRK8GjAz14nQaxKhle30.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_uY1_bHNTrAu2UuUwumZ6AuPc2Egu5fV5FiJ2-fv7ySk.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
.header-region-outer{background-color:#97bfda;}@media screen and (min-width:1024px){.header-region-outer{background-image:url(http://mediad.publicbroadcasting.net/p/wksu/files/201602/WKSU_Header_Skyline.jpg);background-position:center;background-size:cover;background-repeat:no-repeat;}}.branding .tagline{color:#FFFFFF;}.branding .listen-live-toggle > a,.branding .header-utility > a,.branding .header-utility > a.trigger-nav{color:#DEDEDE;}@media screen and (min-width:641px){.branding .trigger-nav{background:#777777;}}@media screen and (max-width:640px){.branding .header-utility > a.trigger-nav,.active-menu .branding .header-utility > a.trigger-nav{color:#777777;}}#listen-live .listen-live-toggle{background-color:#0A88BC;}#listen-live .listen-live-btn{background-color:transparent;color:#DEDEDE;}@media screen and (min-width:640px){#listen-live .listen-live-btn{background-color:#0A88BC;}}.branding .give{background:#A32B19;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Lato:300,700,700italic,900,italic,regular&amp;subset=latin" media="all" />
<link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_eRVoz-O-Udn2obFI7TLsFyeBRhxeGJDVXmIlZ64ZQsg.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wksu.org/sites/wksu.org/files/css/css_SWo6tZlpCPjnhbZDAS4xgnCAofi51J7pbtu4SD2fIug.css" media="all" />
    <script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_xSpMA4ArVcBKOZ43sPqNRk0gxQZdDVifw27pIUCzWU0.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_P9u0bgloveAIlc2kutVCUB_xMaRV3YHWhSVHD3IN5tM.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_-WcrGf3pH5GnSWA1Y-B28tyjknNjFr4asJklCZQ5NUA.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_ZcZajqjC7KCS8_A2dOG5Y53mBT4KJLE7BiKX15HUv7g.js"></script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_SEp4NIM2PD1RhjC3_NDUBbtmniv0x9btV0ghmYjWhNo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src="//stream.publicbroadcasting.net/analytics/aadx.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wksu/files/js/js_rAjxXWYv5hF1Cq4GrStiixlo3a8AluigwZLbUOMQoKw.js"></script>
<script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width">
  </head>

  <body class="html not-front not-logged-in page-node page-node- page-node-26191 node-type-post" >
    <header role="banner" class="header">
  <div class="skiptocontent"><a href="#main-content">skip to main content</a></div>
    <div class="region region-header">
    <div id="block-baby-bear-baby-bear-header" class="block block-baby-bear">

    
  <div class="content">
    
<div class="header-region-outer">
  <section class="header-region-inner row">
    <div class="branding large-12 columns">
      <div class="brand-inner-wrapper">
        <a href="/" rel="home" class="logo" title="WKSU Home"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/201611/wksu_logo_web_0.png" alt="WKSU logo" title="WKSU Home" /></a>         <div class="tagline">
                  </div>
      </div>
      <div class="header-utility">
        <a class="trigger-nav" href="#">
          <span class="icon-list"></span>
          <span class="menu-text">Site Menu</span>
        </a>
        <a class="give" href="https://www.wksu.org/support/pledge/" target="_blank">
  Donate</a>
      </div>
    </div>
  </section>
</div>
  </div>
</div>
  </div>
</header>
    <div class="nav-wrapper mobile">
      <nav>
        <div class="top-bar contain-to-grid" data-topbar>
          <ul class="title-area">
            <li class="toggle-topbar menu-icon">
              <a href="#">Menu</a>
            </li>
          </ul>
          <section class="top-bar-section">
            <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="/">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/news/">News</a>
<ul  class="dropdown">
<li class="left">
<a href="/news/">WKSU News</a>
</li>
<li class="left">
<a href="/topic/terry-pluto/">The View from Pluto</a>
</li>
<li class="left">
<a href="/topic/exploradio/">Exploradio</a>
</li>
<li class="left">
<a href="/topic/shuffle">Shuffle</a>
</li>
<li class="left">
<a href="/topic/election-2016/">Balance of Power</a>
</li>
<li class="left">
<a href="/topic/opioids-turning-tide-crisis">Opioids:  Turning the Tide in the Crisis</a>
</li>
<li class="left">
<a href="/topic/your-vote-ohio">Your Vote Ohio</a>
</li>
<li class="left">
<a href="/topic/state-arts/">State of the Arts</a>
</li>
<li class="left">
<a href="/topic/quick-bites/">Quick Bites</a>
</li>
<li class="left">
<a href="/npr-news/">NPR News</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/wksu-classical-playlist/">Music</a>
<ul  class="dropdown">
<li class="left">
<a href="/wksu-classical-playlist/">Classical Playlists</a>
</li>
<li class="left">
<a href="http://www.folkalley.com/">FolkAlley.com</a>
</li>
<li class="left">
<a href="/topic/shuffle">Shuffle</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/schedule/wksu/">Schedule &amp; Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="/schedule/wksu/">WKSU On-Air Schedule</a>
</li>
<li class="left">
<a href="/schedule/wksu-news/">WKSU News Channel Schedule</a>
</li>
<li class="left">
<a href="/schedule/wksu-hd3/">WKSU Classical Channel Schedule</a>
</li>
<li class="left">
<a href="/printable-schedules/">Printable Schedules</a>
</li>
<li class="left">
<a href="/programs/">Programs A-Z</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/topic/wksu-member-benefits-offers/">Events</a>
<ul  class="dropdown">
<li class="left">
<a href="/topic/wksu-events/">WKSU and Partner Events</a>
</li>
<li class="left">
<a href="/topic/wksu-member-benefits-offers/">Special WKSU Listener Offers</a>
</li>
<li class="left">
<a href="http://wksu.org/topic/cleveland-orchestras-blossom-music-festival/" target="_blank">Blossom Music Festival</a>
</li>
<li class="left">
<a href="/community-calendar/">Community Calendar</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/about-wksu/">About Us</a>
<ul  class="dropdown">
<li class="left">
<a href="/about-wksu/">About WKSU</a>
</li>
<li class="left">
<a href="/topic/wksu-scoop/">WKSU Scoop</a>
</li>
<li class="left">
<a href="/people/category/6">WKSU Staff</a>
</li>
<li class="left">
<a href="/wksu-broadcast-coverage-map/">Broadcast Coverage Area</a>
</li>
<li class="left">
<a href="/wksu-journalism-awards-2016/" target="_blank">WKSU Journalism Awards 2016</a>
</li>
<li class="left">
<a href="/cac/">Community Advisory Council</a>
</li>
<li class="left">
<a href="/financial-and-compliance-information/">Financial and Compliance Information</a>
</li>
<li class="left">
<a href="/contests/">Contest and Drawing Rules</a>
</li>
<li class="left">
<a href="/employment/">Job Opportunities</a>
</li>
<li class="left">
<a href="http://wksu.org/post/corporation-public-broadcasting-faq/" target="_blank">Corporation for Public Broadcasting</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/about-wksu/">Connect</a>
<ul  class="dropdown">
<li class="left">
<a href="/listen-online/">Listen Online</a>
</li>
<li class="left">
<a href="/mobile/">Mobile Apps</a>
</li>
<li class="left">
<a href="/hd/">HD Radio</a>
</li>
<li class="left">
<a href="/rss/">Podcasts</a>
</li>
<li class="left">
<a href="http://wksu.org/how-follow-wksu-facebook/" target="_blank">Facebook</a>
</li>
<li class="left">
<a href="https://www.twitter.com/wksu" target="_blank">Twitter</a>
</li>
<li class="left">
<a href="/e-notes-newsletter/">E-Notes Newsletter</a>
</li>
<li class="left">
<a href="/contact-wksu/">Contact WKSU</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="https://www.wksu.org/support/pledge/" target="_blank">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://www.wksu.org/support/pledge/" target="_blank">Donate Now</a>
</li>
<li class="left">
<a href="/wksu-sustaining-members/">Become a Sustaining Member</a>
</li>
<li class="left">
<a href="/corporate-sponsorship/">Corporate Sponsorship &amp; Underwriting</a>
</li>
<li class="left">
<a href="http://wksu.careasy.org/HOME.html" target="_blank">Vehicle Donation</a>
</li>
<li class="left">
<a href="/leadership-circle/">Leadership Circle</a>
</li>
<li class="left">
<a href="/planned-giving/">Planned Giving</a>
</li>
<li class="left">
<a href="/donations-appreciated-securities-stocks/">Securities</a>
</li>
<li class="left">
<a href="/volunteer-opportunities/">Volunteer</a>
</li>
</ul>
</li>
<li>
<a href="/search/google/">Search</a>
</li>
</ul>
</div>
          </section>
        </div>
      </nav>
    </div>
      <div class="region region-persistent">
    <div id="block-audity-audity" class="block block-audity">

    
  <div class="content">
      </div>
</div>
  </div>
    <div id="page-wrapper">
            <div id="page-document" role="document" class="page">
  <div class="nav-wrapper">
    <nav>
      <div class="top-bar contain-to-grid" data-topbar>
        <ul class="title-area">
          <li class="toggle-topbar menu-icon">
            <a href="#">Menu</a>
          </li>
        </ul>
        <section class="top-bar-section">
          <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="/">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/news/">News</a>
<ul  class="dropdown">
<li class="left">
<a href="/news/">WKSU News</a>
</li>
<li class="left">
<a href="/topic/terry-pluto/">The View from Pluto</a>
</li>
<li class="left">
<a href="/topic/exploradio/">Exploradio</a>
</li>
<li class="left">
<a href="/topic/shuffle">Shuffle</a>
</li>
<li class="left">
<a href="/topic/election-2016/">Balance of Power</a>
</li>
<li class="left">
<a href="/topic/opioids-turning-tide-crisis">Opioids:  Turning the Tide in the Crisis</a>
</li>
<li class="left">
<a href="/topic/your-vote-ohio">Your Vote Ohio</a>
</li>
<li class="left">
<a href="/topic/state-arts/">State of the Arts</a>
</li>
<li class="left">
<a href="/topic/quick-bites/">Quick Bites</a>
</li>
<li class="left">
<a href="/npr-news/">NPR News</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/wksu-classical-playlist/">Music</a>
<ul  class="dropdown">
<li class="left">
<a href="/wksu-classical-playlist/">Classical Playlists</a>
</li>
<li class="left">
<a href="http://www.folkalley.com/">FolkAlley.com</a>
</li>
<li class="left">
<a href="/topic/shuffle">Shuffle</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/schedule/wksu/">Schedule &amp; Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="/schedule/wksu/">WKSU On-Air Schedule</a>
</li>
<li class="left">
<a href="/schedule/wksu-news/">WKSU News Channel Schedule</a>
</li>
<li class="left">
<a href="/schedule/wksu-hd3/">WKSU Classical Channel Schedule</a>
</li>
<li class="left">
<a href="/printable-schedules/">Printable Schedules</a>
</li>
<li class="left">
<a href="/programs/">Programs A-Z</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/topic/wksu-member-benefits-offers/">Events</a>
<ul  class="dropdown">
<li class="left">
<a href="/topic/wksu-events/">WKSU and Partner Events</a>
</li>
<li class="left">
<a href="/topic/wksu-member-benefits-offers/">Special WKSU Listener Offers</a>
</li>
<li class="left">
<a href="http://wksu.org/topic/cleveland-orchestras-blossom-music-festival/" target="_blank">Blossom Music Festival</a>
</li>
<li class="left">
<a href="/community-calendar/">Community Calendar</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/about-wksu/">About Us</a>
<ul  class="dropdown">
<li class="left">
<a href="/about-wksu/">About WKSU</a>
</li>
<li class="left">
<a href="/topic/wksu-scoop/">WKSU Scoop</a>
</li>
<li class="left">
<a href="/people/category/6">WKSU Staff</a>
</li>
<li class="left">
<a href="/wksu-broadcast-coverage-map/">Broadcast Coverage Area</a>
</li>
<li class="left">
<a href="/wksu-journalism-awards-2016/" target="_blank">WKSU Journalism Awards 2016</a>
</li>
<li class="left">
<a href="/cac/">Community Advisory Council</a>
</li>
<li class="left">
<a href="/financial-and-compliance-information/">Financial and Compliance Information</a>
</li>
<li class="left">
<a href="/contests/">Contest and Drawing Rules</a>
</li>
<li class="left">
<a href="/employment/">Job Opportunities</a>
</li>
<li class="left">
<a href="http://wksu.org/post/corporation-public-broadcasting-faq/" target="_blank">Corporation for Public Broadcasting</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/about-wksu/">Connect</a>
<ul  class="dropdown">
<li class="left">
<a href="/listen-online/">Listen Online</a>
</li>
<li class="left">
<a href="/mobile/">Mobile Apps</a>
</li>
<li class="left">
<a href="/hd/">HD Radio</a>
</li>
<li class="left">
<a href="/rss/">Podcasts</a>
</li>
<li class="left">
<a href="http://wksu.org/how-follow-wksu-facebook/" target="_blank">Facebook</a>
</li>
<li class="left">
<a href="https://www.twitter.com/wksu" target="_blank">Twitter</a>
</li>
<li class="left">
<a href="/e-notes-newsletter/">E-Notes Newsletter</a>
</li>
<li class="left">
<a href="/contact-wksu/">Contact WKSU</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="https://www.wksu.org/support/pledge/" target="_blank">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://www.wksu.org/support/pledge/" target="_blank">Donate Now</a>
</li>
<li class="left">
<a href="/wksu-sustaining-members/">Become a Sustaining Member</a>
</li>
<li class="left">
<a href="/corporate-sponsorship/">Corporate Sponsorship &amp; Underwriting</a>
</li>
<li class="left">
<a href="http://wksu.careasy.org/HOME.html" target="_blank">Vehicle Donation</a>
</li>
<li class="left">
<a href="/leadership-circle/">Leadership Circle</a>
</li>
<li class="left">
<a href="/planned-giving/">Planned Giving</a>
</li>
<li class="left">
<a href="/donations-appreciated-securities-stocks/">Securities</a>
</li>
<li class="left">
<a href="/volunteer-opportunities/">Volunteer</a>
</li>
</ul>
</li>
<li>
<a href="/search/google/">Search</a>
</li>
</ul>
</div>
        </section>
      </div>
    </nav>
  </div>

  <div id="player" class="player">
      </div>

  
  
  
  
  <div class="row">
    <main id="content" role="main" class="main-content small-12 columns">
      <article class="story">
        <a id="main-content"></a>
        
                                    
        
        
        
        
        
        
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-26191" class="node node-post node-promoted full row" about="/post/rock-hall-and-jonathan-demme-bring-power-rock-cleveland-new-experience" typeof="sioc:Item foaf:Document">
  <div class="small-12 columns">
        
    
    <h1 itemprop="name" class="post-title">
      Rock Hall and Jonathan Demme Bring the &#039;Power of Rock&#039; to Cleveland in a New Experience    </h1>

  	
    
          <div class="by-date">
        <span class="submitted"><span property="dc:date dc:created" content="2017-06-30T08:29:31-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/kabir-bhatia" rel="author">Kabir Bhatia</a></span></span></span>
        <i class="bullet">&#8226;</i>
        <span class="pub-date">1 hour ago</span>
      </div>
    
    <div class="row">
      <div class="large-2 columns sharing-and-programs">
        
        <div class="social-share clearfix"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4&amp;text=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4&amp;t=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4" class="social-share-item email" title="Email" target="_blank">Email</a></div>      </div>

      <div class="medium-10 medium-pull-1 large-8 large-pull-2 columns post-body-container" >
        <div class="post-body">
          <div class="field field-name-field-image-gallery field-type-image field-label-hidden"><div class="field-items"></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><div class="wysiwyg-asset-image-wrapper offset-left">   <div class="wysiwyg-asset-image">     <a href="http://mediad.publicbroadcasting.net/p/wksu/files/styles/x_large/public/201706/hughes.jpg" class="popup">       <img class="pi_assets-image" data-interchange-default="http://wksu.org/sites/wksu/files/styles/default/public/201706/hughes.jpg" data-interchange-small="http://mediad.publicbroadcasting.net/p/wksu/files/styles/small/public/201706/hughes.jpg" data-interchange-medium="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201706/hughes.jpg" data-interchange-large="http://mediad.publicbroadcasting.net/p/wksu/files/styles/large/public/201706/hughes.jpg" />       <noscript>         <img src="http://wksu.org/sites/wksu/files/styles/default/public/201706/hughes.jpg"  alt="photo of Glenn Hughes, Greg Harris">       </noscript>     </a>     <div class="image-meta">   <div class="caption">Rock Hall CEO Greg Harris (left) and Deep Purple's Glenn Hughes (a 2016 inductee) were on hand to launch the Power of Rock Experience.</div>   <div class="credit">Credit KABIR BHATIA / WKSU</div> </div>   </div> </div>  </p><p>The <a href="https://www.rockhall.com/">Rock and Roll Hall of Fame</a> unveils its $9 million "Power of Rock" theater Saturday, which features a seat-rumbling film of inductees by director Jonathan Demme.</p>  <p>  <div class="audio-container">   <div id="jp-interface--5956442e30293" class="jp-interface">     <div id="post-audio--5956442e30293" class="jp-player" jp-instance="-5956442e30293"></div>      <div class="playpause">       <a href="https://cpa.ds.npr.org/wksu/audio/2017/06/rock_0.mp3" title="Rock Hall&#039;s Connor Theater" class="jp-play"></a>      <a class="jp-pause"></a>     </div>      <div class="audio-meta">       <div class="listen-text-box">         <div class="listen-text">Listen </div>         <div class="listening-text">Listening...</div>       </div>        <div class="jp-controls">         <div class="jp-progress">           <div id="seekbar" class="jp-seek-bar">             <div id="playbar" class="jp-play-bar">               <div class="scrubber">               </div>             </div>           </div>         </div>       </div>        <div class="duration-wrapper">         <div class="jp-custom-current-time"></div>         <span class="divider">&#47;</span>         <div class="jp-custom-duration">0:54</div>       </div>      </div>           <div class="audio-caption">Rock Hall's Connor Theater</div>       </div> </div>  </p><p>The new theater is bathed in purple light and dwarfed by speaker columns, which ties in with <a href="http://wksu.org/post/rock-and-roll-hall-fame-cleveland-remembers-prince">Prince closing the 12-minute film</a> with his now-legendary performance of The Beatles’ “While My Guitar Gently Weeps.” The short film is the centerpiece of the “Power of Rock” experience. Lead designer Christian Lachel says visitors will see footage they’ve never seen before from 32 years’ worth of induction ceremonies.</p> <p>“Even though you may have seen <a href="https://www.youtube.com/watch?v=6SFNW5F8K9Y">the Prince piece before on YouTube</a>, if you go in and actually look at the cut and you look at the different cameras, a lot of these have never been seen by the public. There’s just shots that would make no sense, but emotionally they made sense.”</p> <p>Jonathan Demme is best known for "Silence of the Lambs," "Philadelphia" and the Talking Heads' documentary "Stop Making Sense." His short film on Rock Hall inductees was his final work before he passed away from cancer earlier this year.</p> <p>Glenn Hughes, bassist for <a href="http://wksu.org/news/story/45251">2016 inductees Deep Purple</a>, was on-hand for the preview, and said the theater helps showcase the healing power of music.</p> <p>“I know for a fact that this extremely incredible place that I’m standing in right now changes the lives of many people around our planet. And I’m so honored to be part of this establishment. This is the Power of Rock experience: let you freak flag fly.”</p> <p>The Power of Rock is the gateway to a set of interactive exhibits in which visitors can share their stories. The backlit glass walls featuring inductees' signatures have been retired, and will be replaced with a new exhibit in time for next spring's induction ceremony in Cleveland.</p> <p><div class="flex-video">
  
<iframe class="youtube-player" type="text/html" width="440" height="330" src="http://www.youtube.com/embed/xYL1nzzbkAk" allowfullscreen frameborder="0">
</iframe></div>
</p> </div></div></div><div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/term/rock-and-roll-hall-fame-0" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Rock and Roll Hall of Fame</a></div><div class="field-item odd"><a href="/term/glenn-hughes" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Glenn Hughes</a></div><div class="field-item even"><a href="/term/deep-purple" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Deep Purple</a></div><div class="field-item odd"><a href="/term/greg-harris" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Greg Harris</a></div><div class="field-item even"><a href="/term/chris-connor" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Chris Connor</a></div><div class="field-item odd"><a href="/term/prince-0" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Prince</a></div></div></div><div class="social-share bottom"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4&amp;text=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4&amp;t=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Rock%20Hall%20and%20Jonathan%20Demme%20Bring%20the%20%27Power%20of%20Rock%27%20to%20Cleveland%20in%20a%20New%20Experience&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fy7awzpv4" class="social-share-item email" title="Email" target="_blank">Email</a></div><div id="disqus_thread"><noscript><p><a href="http://npr-wksu.disqus.com/?url=http%3A%2F%2Fwksu.org%2Fpost%2Frock-hall-and-jonathan-demme-bring-power-rock-cleveland-new-experience">View the discussion thread.</a></p></noscript></div>        </div>

        <div class="related">
          <div class="field-name-field-related-posts"><h3>Related Content</h3>
<div id="node-23923" class="node-teaser node node-post node-promoted npr_river_card contains-audio row" about="/post/state-lawmakers-propose-tax-credits-music-recording" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/state-lawmakers-propose-tax-credits-music-recording"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/state-lawmakers-propose-tax-credits-music-recording">State Lawmakers Propose Tax Credits for Music Recording</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2017-05-14T22:33:29-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/mitch-felan" rel="author">Mitch Felan</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">May 14,  2017 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="Roger Mastroianni" href="/post/state-lawmakers-propose-tax-credits-music-recording" class="noexit">
    <img class="multiple" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201610/CIM031416_030.JPG" alt="listening to rehearsal">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          Roger Mastroianni / Cleveland Institute of Music        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>Given the success of Ohio’s Motion Picture Tax Credit, Ohio lawmakers are now trying to offer the same treatment to music recording.</p> <p>State representatives have introduced a bill to give a 25 percent tax credit to musicians who use Ohio recording studios for projects costing more than $10,000. The bill will have an annual cap of $1 million in credits and a per-project cap of $75,000.</p> <p>State Rep. Kent Smith, one of the bill’s sponsors, says the legislation is perfect for Ohio because of the state’s musical assets.</p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-23597" class="node-teaser node node-post node-promoted npr_river_card contains-audio row" about="/post/rock-hall-exhibit-looks-50-years-rolling-stone-down-cigarette-butts" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/rock-hall-exhibit-looks-50-years-rolling-stone-down-cigarette-butts"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/rock-hall-exhibit-looks-50-years-rolling-stone-down-cigarette-butts">Rock Hall Exhibit Looks at 50 Years of &#039;Rolling Stone,&#039; Down to the Cigarette Butts</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2017-05-08T19:12:43-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/kabir-bhatia" rel="author">Kabir Bhatia</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">May 8,  2017 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="" href="/post/rock-hall-exhibit-looks-50-years-rolling-stone-down-cigarette-butts" class="noexit">
    <img class="multiple" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201705/lennon.jpg" alt="photo of John Lennon, Yoko Ono, Rolling Stone">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          ROLLING STONE MAGAZINE        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>A new exhibit at the Rock and Roll Hall of Fame looks back at five decades of pop culture as covered by “Rolling Stone” magazine.</p>  <p>“The Supremes’ Greatest Hits” was the No. 1 album in the country the day “Rolling Stone” first hit newsstands on Nov. 9, 1967.</p> <p>The exhibit features covers from hundreds of issues, including the first one – a promotional still of <a href="http://wksu.org/post/fifty-years-ago-beatles-played-cleveland-one-last-time#stream/0">John Lennon</a> from the film “How I Won the War.” Curator Karen Herman says it was a major task deciding what to include.</p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-17846" class="node-teaser node node-post node-promoted npr_river_card contains-audio row" about="/post/akron-cleveland-events-honor-what-would-have-been-david-bowies-70th-birthday" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/akron-cleveland-events-honor-what-would-have-been-david-bowies-70th-birthday"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/akron-cleveland-events-honor-what-would-have-been-david-bowies-70th-birthday">Akron, Cleveland Events Honor What Would Have Been David Bowie&#039;s 70th Birthday</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2017-01-04T06:46:57-05:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/kabir-bhatia" rel="author">Kabir Bhatia</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Jan 4,  2017 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="" href="/post/akron-cleveland-events-honor-what-would-have-been-david-bowies-70th-birthday" class="noexit">
    <img class="multiple" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201701/bowie.jpg" alt="photo of David Bowie">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          RCA Records        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>Two events in <a href="http://liveatmusica.com/">Akron</a> and <a href="http://coolcleveland.com/2016/11/bowie-show-tix-now-sale/">Cleveland</a> this month will mark what would have been David Bowie’s 70th birthday. Thomas Mulready -- founder of IngenuityFest and the website, <a href="http://coolcleveland.com/">CoolCleveland</a> – will present a multimedia look at Bowie’s entire career this month.</p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-17286" class="node-teaser node node-post node-promoted npr_river_card contains-audio row" about="/post/pearl-jam-yes-journey-and-elo-will-be-new-members-rock-and-roll-hall-fame" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/pearl-jam-yes-journey-and-elo-will-be-new-members-rock-and-roll-hall-fame"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/pearl-jam-yes-journey-and-elo-will-be-new-members-rock-and-roll-hall-fame">Pearl Jam, Yes, Journey and ELO Will Be New Members of the Rock and Roll Hall of Fame</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2016-12-20T09:30:52-05:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/kabir-bhatia" rel="author">Kabir Bhatia</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Dec 20,  2016 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="KABIR BHATIA" href="/post/pearl-jam-yes-journey-and-elo-will-be-new-members-rock-and-roll-hall-fame" class="noexit">
    <img class="multiple" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201612/rockhall17_0.jpg" alt="photo of Rock Hall artists">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          KABIR BHATIA / WKSU        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>The Rock and Roll Hall of Fame has announced its inductees for the Class of 2017.</p>   <p>This year's class includes several first time nominees -- such as Yes, Journey and the Electric Light Orchestra -- all of whom have been eligible for years.</p> <p>Grunge rock pioneers Pearl Jam will be inducted in their first year of eligibility, which is defined as 25 years after an act releases its first record.</p> <p>Rounding out this year's class are Joan Baez and rapper Tupac Shakur.</p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-11678" class="node-teaser node node-post node-promoted npr_river_card contains-audio row" about="/post/fifty-years-ago-beatles-played-cleveland-one-last-time" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/fifty-years-ago-beatles-played-cleveland-one-last-time"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/fifty-years-ago-beatles-played-cleveland-one-last-time">Fifty Years Ago, The Beatles Played Cleveland One Last Time</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2016-12-01T10:53:21-05:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/kabir-bhatia" rel="author">Kabir Bhatia</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Dec 1,  2016 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="" href="/post/fifty-years-ago-beatles-played-cleveland-one-last-time" class="noexit">
    <img class="multiple" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/medium/public/201608/poster.jpg" alt="photo of Beatles 1966 concert poster">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          BEATLESBIBLE.COM        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>Fifty years ago today, <a href="https://www.beatlesbible.com/1966/08/14/live-cleveland-stadium-cleveland-ohio/">The Beatles played Cleveland for the second</a> -- and last -- time.  The band's show at Cleveland Municipal Stadium on <a href="https://www.youtube.com/watch?v=bYLfhWzG3ek">August 14, 1966</a> was part of their final tour.  Just 15 days later, they would give up touring forever following a show at San Francisco’s Candlestick Park.  Their tour that year was marred by backlash to John Lennon’s comment that the group was “bigger than Jesus,” as well as noisy, sometimes unruly crowds</p></p></div></div></div>    </div>

      </div>
</div>
</div>        </div>
      </div>
    </div>
      </div>
</div>
  </div>
</div>
  </div>
              </article>
    </main>
  </div>

      <section class="post-content">
      <div>
          <div class="region region-post-content">
    <div id="block-pi-responsive-ads-mobile-1" class="block block-pi-responsive-ads">

    
  <div class="content">
      </div>
</div>
  </div>
      </div>
    </section>
  
  <div class="bottom-ads">
    <div class="bottom-ads-inner"></div>
  </div>
</div>

<footer class="footer" role="contentinfo">
  <div class="row">
    <div class="footer-affiliate-container small-centered columns">
                  <div class="region region-footer">
    <div id="block-pi-table-queue-partnerfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-partnerfooter">
  <p class="partnerslabel">
  </p>
<div class="item-list"><ul class="partner-logos"><li class="first"><a href="http://www.npr.org" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/partner_footer_logo/public/201601/npr-logo.png" alt="NPR" title="NPR" /></a></li>
<li><a href="http://www.pri.org" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/partner_footer_logo/public/201601/pri-logo.png" alt="Public Radio International" title="Public Radio International" /></a></li>
<li><a href="http://www.americanpublicmedia.org" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/partner_footer_logo/public/201601/apm-logo.png" alt="American Public Media" title="American Public Media" /></a></li>
<li><a href="http://www.prx.org" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/partner_footer_logo/public/201601/prx-logo.png" alt="Public Radio Exchange" title="Public Radio Exchange" /></a></li>
<li class="last"><a href="http://www.bbc.com" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wksu/files/styles/partner_footer_logo/public/201601/bbc-logo.png" alt="BBC" title="BBC" /></a></li>
</ul></div></div>
  </div>
</div>
<div id="block-pi-table-queue-auxiliarylinksfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-auxiliarylinksfooter">
  <div class="item-list"><ul class="auxiliary-links"><li class="first"><span>&copy; 2017 WKSU</span></li>
<li><a href="http://www.kent.edu" target="_blank">A Service of Kent State University</a></li>
<li><a href="http://www.wksu.org/contests/" target="_self">Contest and Drawing Rules</a></li>
<li><a href="http://wksu.org/contact-wksu/" target="_self">Contact WKSU</a></li>
<li class="last">1613 East Summit Street<br />Kent, Ohio 44242<br />330-672-3114<br /></li>
</ul></div></div>
  </div>
</div>
  </div>
          </div>
  </div>
</footer>
      <script type="text/javascript">
  var _sf_async_config=Drupal.settings.chartbeat;
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src',
         (("https:" == document.location.protocol) ? "https://s3.amazonaws.com/" : "http://") +
         "static.chartbeat.com/js/chartbeat.js");
      document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
       loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script><script type="text/javascript">
<!--//--><![CDATA[//><!--
 (function ($) { $(document).foundation({ topbar: { custom_back_text: true, back_text: 'back', mobile_show_parent_link: true } }); }(jQuery));
//--><!]]>
</script>
    </div>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"15ba4da3e8","applicationID":"1108724","transactionName":"NlMBMhAECEZRAU1eDg8ZIgUWDAlbHwxWUwQ+RgIBBzoQXFUV","queueTime":0,"applicationTime":637,"atts":"GhQCRFgeG0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
